[Resolved] Service Availability
Incident Report for Mediaclip
Resolved
We experienced a technical issue affecting our backend services. Between 10:22 AM and 10:44 AM (UTC), customers might have experienced issues creating new projects and/or uploading photos.
The root cause has been identified and the issue is resolved.
Posted Nov 29, 2023 - 05:30 EST